Category Archives: Windows

Dell’s WinXP installer messes up OSX partitions when using Boot Camp

A few days ago I decided to install WinXP on my Intel based iMac, using Boot Camp.

Boot Camp assistant worked great, it created a new Boot Camp partition on the hard drive just as planned with a 32 GB partition. Popping in a Dell WinXP SP2 CD (from a now long gone computer) as instructed, but when prompted to select where to install XP the Boot Camp partition was gone. In fact, so was the OSX partition…
The weird thing was that the XP installer suggested I should install it to a 131 GByte partition on the disk – where did it get that from?

Luckily I have a nightly Carbon Copy Cloner job scheduled for the iMac, so restoring the OSX disk was pretty straightforward (even though it took some 5-6 hours to restore 500 GB of data).

Tried the same procedure twice more. Once with the same result, and once I the OSX partition was actually intact. But XP still suggested I’d install it to the non-existing 131 GB partition.

Fourth time I tried another XP disc, and this time also slipstreamed it with SP3 using nLite (awesome product!). And now it worked flawlessly.

After doing some research it seems that some people are having trouble using Dell XP CDs with Boot Camp. Not sure why, but using that other, generic XP CD made the problem disappear. Or if it was the SP3 slipstreaming – either way it now works. I guess you could argue that the Dell CD was intended to be used with Dell machines only, and in this case that  turns out to be true.. Anyway, with the problems sorted out, dual booting works great!

Dell XPS M1330 – end of story

Long overdue, here is the final chapter in the warranty story going on with Dell.

They indeed repaired the laptop – at least in part. The graphics now works as it should, but the computer is still unstable and hangs way too often to be useful, even with fresh installations of Vista. Loosing work because the computer hangs at random times (several times per hour) just isn’t an option… No idea what’s causing it – feels like it may be poor thermal design/overheating. But that’s just a guess.

Nice of Dell to repair the broken GPU, but too bad they didn’t make the laptop usable again.

Dell XPS M1330 NVIDIA troubles… progress!

Turns out Dell’s tech support wasn’t the way to go.
After being told the laptop was 2 months out of warranty I had a chat with the sales guy who sold us the laptop two years ago. Friday last week he promised to look into the case and get back by Tuesday this week latest. That he did, with the good news that Dell would repair the laptop without cost to me.

Now that’s good support! Let’s just hope that is the end of the story.

Dell XPS M1330 – Nvidia GPU failing

Been using a Dell XPS M1330 at work from December 2007 until last fall (October 2009). It  worked well until it in September 2009 started to act suspiciously, crashing from time to time. Problems escalating and in October it died. The symptoms were thin verticals colored lines that successively grew more intensive until the screen was all white.

Called Dell support who said “sorry – you had a one-year warranty – it expired in December 2008”. Frustrated with a month of crashing Vista I upgraded to a MacBook Pro (great machine btw).  The Dell laptop found a resting place in a drawer.

I’ve kept the laptop in good order, not banged it around too much, always upgraded with latest BIOS and Vista updates etc.

You would think that’s the end of the story… Not so.

A few days ago I stumbled upon a forum post where people were upset about Dell’s poor attitude towards users having problems with their GPUs in certain Dell laptop models. Turns out their problems were the same as I experienced on my M1330 (which has a 128 MB NVIDIA GeForce 8400M GS). Also seems Dell has been aware of the problems for quite some time, but not issued a recall or even a warning to customers who had bought the affected models.

A quick google search reveals the problem seems to be quite well known, there are also videos online showing what the problem looks like.

Btw, a way of testing whether it’s the GPU or display that’s causing the problem is to hold down the “D” key while pressing the power button. The display should now cycle between various solid colors (red, green, blue etc) before continuing to boot in graphical mode (which will fail if the GPU is broken). But if you see the solid colors ok, your display is fine.

So is this an isolated problem for Dell only? Of course not:

Dell has acknowledged there are issues with the Nvidia GPU and offer a 12 month extended warranty to cover for those affected.

HP is also affected, a very long thread in their forum shows HP users are also upset. It seems they have informed their customers though, at least according to CNet and Engadget.

Same thing for Sony, their take is to offer a good and relevant extended warranty: “Sony is offering to repair yours for free within four years of the purchase date, irrespective of warranty status. 

Apple finally is not immune either, but they also offer a good extended warranty: “If the NVIDIA graphics processor in your MacBook Pro has failed, or fails within three years of the original date of purchase, a repair will be done free of charge, even if your MacBook Pro is out of warranty.”

Here is where I am starting to get really upset.

I was told by Dell support in October that the laptop was out of warranty and they wouldn’t repair it. They told me nothing of extended warranty to cover for defective GPUs.

Six months later (=now) I find out that I was in fact eligible for the extended warranty back in Octobert, but now Dell tells me it’s too late – “You are two months past the warranty period”.

Let’s see where this goes – I’ll be pushing to get the GPU fixed. Will be interesting to see what Dell’s position on this is, I’ll post updates here – whether it’s good news or bad.