Category Archives: QNAP

QNAP TS-219 + Western Digital Green drives = FAIL!!

These days I am all in on the Intel Atom based Netgear NAS products, using a RN312. Very nice NAS, so far.

2013-08-15_13-06-12

The previous NAS in the server rack was a dual disk QNAP TS-219. Lower spec:ed with 512 MB RAM and an ARM based CPU. Still, it provided quite nice performance, and QNAP has been really good at releasing new firmware also for their older NAS versions (better than Netgear, actually, who won’t release their latest OS for the Ultra series, for example). 

Anyway, in preparation for selling the QNAP I figured I would put a couple of 1 TB Western Digital Green disks (that I wasn’t using) in it, upgrade to latest firmware, format the disks etc – everything to make it as nice as possible for potential buyers.

2013-08-15_13-08-53

After A LOT of trying, re-trying and trying again I gave up. It just didn’t work. The QNAP would recognise both disks, but performance was just terrible. Logging in via ssh and typing text worked – sometimes – but just as often it took 10-20 seconds between characters could be typed on the keyboard.

The web UI was equally unresponsive. When trying to combine the disks into a RAID 1 it just didn’t work. Total FAIL.

I guess I should have read the manual… On QNAP’s web site there is a compatibility list, with drives both suitable and NOT suitable for their NAS products. The list of unsuitable drives is not too long, but the Western Digital drives were on it. Come on… These drives are hugely common on the market.. why wouldn’t they be supported? What can be so strange about them?

Anyway, after replacing them with a couple of 250 GB Seagate Barracuda 7200.9 drive things were super smooth and the NAS was running like never before. All good in the end thus.

Lesson learned: Start looking for explanations online before spending too much time trying to solve things yourself..